Your browser does not support JavaScript!
國立清華大學工程與系統科學系
國立清華大學工程與系統科學系
繁體
分類清單
首頁 > 最新消息-站務及電腦Q&A
[清大計中]【漏洞預警】特定版本Samba軟體存在允許攻擊者遠端執行任意程式碼之漏洞(CVE-2017-7494),可取得管理者權限,請儘速確認Samba軟體版本並進行更新

教育機構ANA通報平台

 

發佈編號 發佈時間
事故類型 ANA-漏洞預警 發現時間 2017-05-25 00:00:00
影響等級    
[主旨說明:]【漏洞預警】特定版本Samba軟體存在允許攻擊者遠端執行任意程式碼之漏洞(CVE-2017-7494),可取得管理者權限,請儘速確認Samba軟體版本並進行更新
[內容說明:]
轉發行政法人國家資通安全科技中心 資安訊息警訊 NCCST-ANA-201705-0129

Samba是一種用來使Unix/Linux作業系統與微軟Windows作業系統伺服器訊息區塊(Server Message Block,SMB,又名網路檔案分享系統)協定進行連結的軟體,可運用於共享檔案與網路印表機,以及扮演網域控制站(Domain Controller)角色。

研究人員發現存在超過7年之漏洞,該漏洞是Samba軟體在處理共享函式庫(share library)時存在問題,導致遠端攻擊者只需扮演具有寫入Samba伺服器目錄權限的用戶,並上傳惡意的共享函式庫,伺服器便會載入與執行該共享函式庫,進而在伺服器執行任意程式碼獲得管理者權限。目前CVE對此弱點之編號為CVE 2017-7494。雖尚未傳出實際的案例,但因實現的難度低,且不需使用者介入便可讓攻擊者取得系統權限,因此此弱點又可被視為Linux版的SMB弱點(例如WannaCry所用),請儘速確認Samba軟體版本並進行更新或強化。

此訊息僅發送到「區縣市網路中心」,煩請貴單位協助公告或轉發
[影響平台:]
Samba版本大於3.5.0與小於4.4.14/4.5.10/4.6.4
[建議措施:]
1.目前Samba官方已針對此弱點釋出修復之版本(https://www.samba.org/samba/history/security.html)
 
請將Samba軟體更新至以下修復之版本,另請密切注意Samba官方網頁,以確認是否有相關延伸性之弱點。
Samba >= 4.6.4
Samba >= 4.5.10
Samba >= 4.4.14

2.若現階段無法立即更新Samba軟體之版本,則可至smb.conf中的[global]區塊添加nt pipe support = no參數,以減緩漏洞所造成的影響。

3.透過防火牆或相關防護產品,阻擋來自Internet對Samba伺服器通訊埠(TCP 445)之連線。
[參考資料:]
1. https://www.samba.org/samba/security/CVE-2017-7494.html
 

2. http://thehackernews.com/2017/05/samba-rce-exploit.html
 

 

(此通報僅在於告知相關資訊,並非為資安事件)如果您對此通報的內容有疑問或有關於此事件的建議,歡迎與我們連絡。
教育機構資安通報應變小組
網址:https://info.cert.tanet.edu.tw/
 

專線電話:07-5250211
網路電話:98400000
E-Mail:service@cert.tanet.edu.tw

 

瀏覽數  
將此文章推薦給親友
請輸入此驗證碼
Voice Play
更換驗證碼